From a8e354c7fad70eb7fdfda62ec83faf1be6c4ed44 Mon Sep 17 00:00:00 2001
From: Samo Penic <samo.penic@gmail.com>
Date: Tue, 24 Jan 2023 20:03:01 +0000
Subject: [PATCH] Changes in code and README for easier compilation. May break something

---
 configure.ac |   17 +++++++++++------
 1 files changed, 11 insertions(+), 6 deletions(-)

diff --git a/configure.ac b/configure.ac
index 4a01fa5..14e03ac 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,14 +1,16 @@
 #                                               -*- Autoconf -*-
 # Process this file with autoconf to produce a configure script.
 
-AC_PREREQ([2.67])
-AC_INIT([FULL-PACKAGE-NAME], [VERSION], [BUG-REPORT-ADDRESS])
+AC_PREREQ([2.71])
+AC_INIT([trisurf_ng],[1.0],[samo.penic@fe.uni-lj.si])
 AC_CONFIG_SRCDIR([config.h.in])
 AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_MACRO_DIRS([m4])
 AM_INIT_AUTOMAKE
 # Checks for programs.
 AC_PROG_CC
-
+LT_INIT
+LT_INIT
 # Checks for libraries.
 # FIXME: Replace `main' with a function in `-lconfuse':
 AC_CHECK_LIB([confuse], [cfg_parse])
@@ -29,7 +31,7 @@
 
 dnl Check if we have enable debug support.
 AC_MSG_CHECKING(whether to enable debugging)
-debug_default="yes"
+debug_default="no"
 AC_ARG_ENABLE(debug, [ --enable-debug=[no/yes] turn on debugging
 [default=$debug_default]],, enable_debug=$debug_default)
 dnl Yes, shell scripts can be used
@@ -41,12 +43,15 @@
 AC_MSG_RESULT(no)
 fi
 
+#AC_DEFINE_UNQUOTED(TS_VERSION,
+#                    ["Trisurf (commit `git describe  --abbrev=6 --dirty --always --tags`) build on `date` @`hostname`."],
+#                    [A string containing the version number])
+
 # Checks for library functions.
 AC_FUNC_MALLOC
 AC_FUNC_REALLOC
 AC_CHECK_FUNCS([pow sqrt strndup])
 
 AC_CONFIG_FILES([Makefile
-                 src/Makefile
-                 test/Makefile])
+                 src/Makefile])
 AC_OUTPUT

--
Gitblit v1.9.3