From e19e790e95f14ca69a7ce9c5e45d815fe21df36e Mon Sep 17 00:00:00 2001
From: Samo Penic <samo.penic@gmail.com>
Date: Tue, 10 Jul 2012 12:33:43 +0000
Subject: [PATCH] It seems bondflip is fixed. Before 'for' loops I had to set j=0 in vertex.c and triangle.c in remove_neighbour

---
 configure.ac |   28 ++++++++++++++++++++++++----
 1 files changed, 24 insertions(+), 4 deletions(-)

diff --git a/configure.ac b/configure.ac
index 2c4ec30..791a930 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,24 +1,44 @@
 #                                               -*- Autoconf -*-
 # Process this file with autoconf to produce a configure script.
 
-AC_PREREQ([2.50])
+AC_PREREQ([2.67])
 AC_INIT([FULL-PACKAGE-NAME], [VERSION], [BUG-REPORT-ADDRESS])
-AM_INIT_AUTOMAKE
 AC_CONFIG_SRCDIR([config.h.in])
 AC_CONFIG_HEADERS([config.h])
-
+AM_INIT_AUTOMAKE
 # Checks for programs.
 AC_PROG_CC
 
 # Checks for libraries.
+# FIXME: Replace `main' with a function in `-lconfuse':
+AC_CHECK_LIB([confuse], [cfg_parse])
+# FIXME: Replace `main' with a function in `-lm':
+AC_CHECK_LIB([m], [pow])
 
 # Checks for header files.
-AC_CHECK_HEADERS([stdlib.h])
+AC_CHECK_HEADERS([stdlib.h string.h])
 
 # Checks for typedefs, structures, and compiler characteristics.
+AC_C_INLINE
+
+dnl Check if we have enable debug support.
+AC_MSG_CHECKING(whether to enable debugging)
+debug_default="yes"
+AC_ARG_ENABLE(debug, [ --enable-debug=[no/yes] turn on debugging
+[default=$debug_default]],, enable_debug=$debug_default)
+dnl Yes, shell scripts can be used
+if test "x$enable_debug" = "xyes"; then
+CFLAGS="-g -O2 -DDEBUG"
+AC_MSG_RESULT(yes)
+else
+CFLAGS="-O3 -ffast-math"
+AC_MSG_RESULT(no)
+fi
 
 # Checks for library functions.
 AC_FUNC_MALLOC
+AC_FUNC_REALLOC
+AC_CHECK_FUNCS([pow sqrt strndup])
 
 AC_CONFIG_FILES([Makefile
                  src/Makefile

--
Gitblit v1.9.3