From 3197854e89eb9ffe5ff3137e274d16806c2028a5 Mon Sep 17 00:00:00 2001
From: Samo Penic <samo.penic@gmail.com>
Date: Tue, 27 Jul 2021 12:51:09 +0000
Subject: [PATCH] Found one bug in the code when calculating mprod. Fixed.

---
 configure.ac |   20 +++++++++++++++-----
 1 files changed, 15 insertions(+), 5 deletions(-)

diff --git a/configure.ac b/configure.ac
index 791a930..8134005 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,18 +2,25 @@
 # Process this file with autoconf to produce a configure script.
 
 AC_PREREQ([2.67])
-AC_INIT([FULL-PACKAGE-NAME], [VERSION], [BUG-REPORT-ADDRESS])
+AC_INIT([trisurf_ng], [1.0], [samo.penic@fe.uni-lj.si])
 AC_CONFIG_SRCDIR([config.h.in])
 AC_CONFIG_HEADERS([config.h])
 AM_INIT_AUTOMAKE
 # Checks for programs.
 AC_PROG_CC
-
+LT_INIT
+AC_PROG_LIBTOOL
 # Checks for libraries.
 # FIXME: Replace `main' with a function in `-lconfuse':
 AC_CHECK_LIB([confuse], [cfg_parse])
 # FIXME: Replace `main' with a function in `-lm':
 AC_CHECK_LIB([m], [pow])
+
+AC_CHECK_LIB([gslcblas],[cblas_dgemm])
+AC_CHECK_LIB([gsl],[gsl_blas_dgemm])
+#AC_CHECK_LIB([xml2],[xmlNodeListGetString])
+PKG_CHECK_MODULES([libxml2], [libxml-2.0])
+AC_CHECK_LIB([z],[deflate])
 
 # Checks for header files.
 AC_CHECK_HEADERS([stdlib.h string.h])
@@ -23,7 +30,7 @@
 
 dnl Check if we have enable debug support.
 AC_MSG_CHECKING(whether to enable debugging)
-debug_default="yes"
+debug_default="no"
 AC_ARG_ENABLE(debug, [ --enable-debug=[no/yes] turn on debugging
 [default=$debug_default]],, enable_debug=$debug_default)
 dnl Yes, shell scripts can be used
@@ -35,12 +42,15 @@
 AC_MSG_RESULT(no)
 fi
 
+#AC_DEFINE_UNQUOTED(TS_VERSION,
+#                    ["Trisurf (commit `git describe  --abbrev=6 --dirty --always --tags`) build on `date` @`hostname`."],
+#                    [A string containing the version number])
+
 # Checks for library functions.
 AC_FUNC_MALLOC
 AC_FUNC_REALLOC
 AC_CHECK_FUNCS([pow sqrt strndup])
 
 AC_CONFIG_FILES([Makefile
-                 src/Makefile
-                 test/Makefile])
+                 src/Makefile])
 AC_OUTPUT

--
Gitblit v1.9.3